Attachment blocking stopping outgoing emails, but Local Blocking is set to 'no check'

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Attachment blocking stopping outgoing emails, but Local Blocking is set to 'no check'

James Brown
Version 2.5.4(16318)

BlockWLExes is set to ‘no check’ but a local user was unable to send a password-protected zip file:

Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] 127.0.0.1 <[hidden email]> to: [hidden email] [Plugin] calling plugin ASSP_AFC
Nov-15-16 10:45:11 [Worker_2] Warning: possibly virus infected file (can't set extraction path for entry 'Church Wardens��� Annual Report 2016.pages/' to '/Applications/assp/tmp/zip_2_1479167111/.10/Church Wardens��� Annual Report 2016.pages/' in archive) '/Applications/assp/tmp/zip_2_1479167111/utf_8_Church_20Wardens_E2_80_99_20Annual_20Report_202016.pages.zip' - <-25> -
Nov-15-16 10:45:11 [Worker_2] Warning: fatal - libarchive extract '/Applications/assp/tmp/zip_2_1479167111/utf_8_Church_20Wardens_E2_80_99_20Annual_20Report_202016.pages.zip' - <-25> -
Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] [Attachment] 127.0.0.1 <[hidden email]> to: [hidden email] SPAM FOUND bad attachment 'utf-8''Church%20Wardens%E2%80%99%20Annual%20Report%202016.pages.zip' cause: 'encrypted compressed file 'utf-8''Church%20Wardens%E2%80%99%20Annual%20Report%202016.pages.zip''
Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] [Attachment] 127.0.0.1 <[hidden email]> to: [hidden email] mail blocked by Plugin ASSP_AFC - reason BadAttachment
Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] [Attachment] 127.0.0.1 <[hidden email]> to: [hidden email] [spam found] (BadAttachment) [Warden s Report];
No

ASSP_AFC version is 4.40

Have I configured something incorrectly?

Thanks,

James.

------------------------------------------------------------------------------
_______________________________________________
Assp-test mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-test
Reply | Threaded
Open this post in threaded view
|

Re: Attachment blocking stopping outgoing emails, but Local Blocking is set to 'no check'

Thomas Eckardt/eck
please post the complete

    Content-Disposition: attachment; .....

header of this mail.

>Have I configured something incorrectly?
No.

There are two things making problems.

1. libarchive makes problems to handle UTF-8 file names - hope I can workaround this.
2. the client uses not the default MIME encoding in the header, instead 'url-encoding' is used : Content-Disposition: attachment; filename*=UTF-8''Na%C3%AFve%20file.txt

assp should be able to decode this - how ever it was not working here.

Thomas



Von:        James Brown <[hidden email]>
An:        ASSP development mailing list <[hidden email]>
Datum:        15.11.2016 01:02
Betreff:        [Assp-test] Attachment blocking stopping outgoing emails, but Local Blocking is set to 'no check'




Version 2.5.4(16318)

BlockWLExes is set to ‘no check’ but a local user was unable to send a password-protected zip file:

Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] 127.0.0.1 <[hidden email]> to: [hidden email] [Plugin] calling plugin ASSP_AFC
Nov-15-16 10:45:11 [Worker_2] Warning: possibly virus infected file (can't set extraction path for entry 'Church Wardens��� Annual Report 2016.pages/' to '/Applications/assp/tmp/zip_2_1479167111/.10/Church Wardens��� Annual Report 2016.pages/' in archive) '/Applications/assp/tmp/zip_2_1479167111/utf_8_Church_20Wardens_E2_80_99_20Annual_20Report_202016.pages.zip' - <-25> -
Nov-15-16 10:45:11 [Worker_2] Warning: fatal - libarchive extract '/Applications/assp/tmp/zip_2_1479167111/utf_8_Church_20Wardens_E2_80_99_20Annual_20Report_202016.pages.zip' - <-25> -
Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] [Attachment] 127.0.0.1 <[hidden email]> to: [hidden email] SPAM FOUND bad attachment 'utf-8''Church%20Wardens%E2%80%99%20Annual%20Report%202016.pages.zip' cause: 'encrypted compressed file 'utf-8''Church%20Wardens%E2%80%99%20Annual%20Report%202016.pages.zip''
Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] [Attachment] 127.0.0.1 <[hidden email]> to: [hidden email] mail blocked by Plugin ASSP_AFC - reason BadAttachment
Nov-15-16 10:45:11 id-67111-00658 [Worker_2] [TLS-out] [Attachment] 127.0.0.1 <[hidden email]> to: [hidden email] [spam found] (BadAttachment) [Warden s Report];
No

ASSP_AFC version is 4.40

Have I configured something incorrectly?

Thanks,

James.

------------------------------------------------------------------------------
_______________________________________________
Assp-test mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-test




DISCLAIMER:
*******************************************************
This email and any files transmitted with it may be confidential, legally privileged and protected in law and are intended solely for the use of the
individual to whom it is addressed.
This email was multiple times scanned for viruses. There should be no known virus in this email!
*******************************************************


------------------------------------------------------------------------------

_______________________________________________
Assp-test mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-test
Reply | Threaded
Open this post in threaded view
|

Re: Attachment blocking stopping outgoing emails, but Local Blocking is set to 'no check'

James Brown
Thanks Thomas.

On 16 Nov 2016, at 11:48 pm, Thomas Eckardt <[hidden email]> wrote:

please post the complete

    Content-Disposition: attachment; .....

header of this mail.

The attachment part of the message starts:

--Apple-Mail-59494190-EAB3-47FE-B0E6-81829710D241
Content-Type: application/x-iwork-pages-sffpages;
name="Church Wardens_ Annual Report 2016.pages";
x-apple-part-url=5E3A5D59-614D-492E-BE34-3710478C5B4B
Content-Disposition: attachment;
filename*=GB2312''Church%20Wardens%A1%AF%20Annual%20Report%202016.pages
Content-Transfer-Encoding: base64

.pages files are actually zipped folders I think.


>Have I configured something incorrectly?
No.

There are two things making problems.

1. libarchive makes problems to handle UTF-8 file names - hope I can workaround this.
2. the client uses not the default MIME encoding in the header, instead 'url-encoding' is used : Content-Disposition: attachment; filename*=UTF-8''Na%C3%AFve%20file.txt

assp should be able to decode this - how ever it was not working here.

Thomas

Client is Mail.app on macOS Sierra.

Thanks again,

James.

------------------------------------------------------------------------------

_______________________________________________
Assp-test mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-test