Getting ASSP to use Mysql

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Getting ASSP to use Mysql

James Moe-2
Hello,
  assp 2.5.5 (17073)
  linux 4.4.62-18.6-default x86_64
  perl 5.18.2

  ASSP is recommending that I use a database to manage data.

  myhost: localhost
  DBdriver: mysql
  mydb: asspdb
  myuser: assp_admin
  mypassword: ************

$  ll mysql/dbimport/
total 28804
-rw-r--r-- 1 root root    33843 May 27 13:48 delay.add
-rw-r--r-- 1 root root 29182952 May 27 13:46 spamdb.add
-rw-r--r-- 1 root root   274019 May 27 13:47 whitelist.add

  I did all of the above. The database exists. The database credentials
are valid.
- I checked "Import all files..."
- I selected the "Apply Changes and ..." button
- Additional red text appeared.

  Nothing happened. No tables were created in the database. The only
entry in the log file:
 2017-05-27 14:05:15 Admin Update: task ImportMysqlDB was queued to run
in worker 10000

  No entries in the mysql logs.
  Apparently the process quietly dies without even a whimper.

  What next?

--
James Moe
moe dot james at sohnen-moe dot com
520.743.3936
Think.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Getting ASSP to use Mysql

James Moe-2
On 05/27/2017 02:26 PM, James Moe wrote:
>   Nothing happened. No tables were created in the database.
>   No entries in the mysql logs.
>   Apparently the process quietly dies without even a whimper.
>
>   What next?
>
  No one knows?

  As a result of this effort, ASSP was destabilized (see "ASSP silently
crashes"). No database tables were created, no indication of any kind of
effort, yet ASSP consumed memory until it crashed.

--
James Moe
moe dot james at sohnen-moe dot com
520.743.3936
Think.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Getting ASSP to use Mysql

Alexandre de Arruda Paes
Hi,

In assp base dir, do you have the file assp_db_import.cfg ?

Alexandre

2017-05-31 15:53 GMT-03:00 James Moe <[hidden email]>:
On 05/27/2017 02:26 PM, James Moe wrote:
>   Nothing happened. No tables were created in the database.
>   No entries in the mysql logs.
>   Apparently the process quietly dies without even a whimper.
>
>   What next?
>
  No one knows?

  As a result of this effort, ASSP was destabilized (see "ASSP silently
crashes"). No database tables were created, no indication of any kind of
effort, yet ASSP consumed memory until it crashed.

--
James Moe
moe dot james at sohnen-moe dot com
520.743.3936
Think.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Getting ASSP to use Mysql

James Moe-2
On 06/01/2017 06:49 AM, Alexandre de Arruda Paes wrote:
>
> In assp base dir, do you have the file assp_db_import.cfg ?
>
  Yes. Here are the first two lines:
# version='2.4.3';
# modversion='(15119)';

--
James Moe
moe dot james at sohnen-moe dot com
520.743.3936
Think.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Getting ASSP to use Mysql

Robert K Coffman Jr. -Info From Data Corp.
Here are my notes from when I did this.  A key factor for me was doing
it in a test environment first - no surprises like dying ASSP in prod.

HTH:

install mysql:
       
        sudo apt-get install mysql-server
        new password:  (SEE KEEPASS)

sudo mysql -u root -p
        mysql> CREATE DATABASE asspdb;
        quit

run sudo ls (so that you have sudo available) then run:

cd /usr/share/assp/mysql/dbimport
sudo cp /usr/share/assp/spamdb    ./spamdb.add
sudo cp /usr/share/assp/whitelist  ./whitelist.add
sudo cp /usr/share/assp/redlist    ./redlist.add
sudo cp /usr/share/assp/persblack         ./persblackdb.add
sudo cp /usr/share/assp/delaydb          ./delaydb.add
sudo cp /usr/share/assp/delaydb.white     ./delaydb.white.add
sudo cp /usr/share/assp/ldaplist  ./ldaplist.add
sudo cp /usr/share/assp/pb/pbdb.black.db  ./pbdb.black.db.add
sudo cp /usr/share/assp/pb/pbdb.mxa.db    ./pbdb.mxa.db.add
sudo cp /usr/share/assp/pb/pbdb.ptr.db    ./pbdb.ptr.db.add
sudo cp /usr/share/assp/pb/pbdb.rbl.db    ./pbdb.rbl.db.add
sudo cp /usr/share/assp/pb/pbdb.rwl.db    ./pbdb.rwl.db.add
sudo cp /usr/share/assp/pb/pbdb.spf.db    ./pbdb.spf.db.add
sudo cp /usr/share/assp/pb/pbdb.uribl.db  ./pbdb.uribl.db.add
sudo cp /usr/share/assp/pb/pbdb.white.db  ./pbdb.white.db.add
sudo cp /usr/share/assp/pb/pbdb.dkim.db   ./pbdb.dkim.db.add
sudo cp /usr/share/assp/pb/pbdb.sb.db     ./pbdb.sb.db.add
ls


In the ASSP GUI, under File Paths and Database, change these settings:
database hostname or IP (myhost)  - 127.0.0.1
database name (mydb)  - asspdb
database username (myuser)        - root
database password (mypassword)    - SEE KEEPASS
Change backup Database Interval (backupDBInterval) to 24.

In the ASSP GUI, change all these (under Files Paths and Database)

Change these to "DB:" (no quotes)
spamdb
whitelistdb
redlistdb
persblackdb
ldaplistdb
delaydb

(Under PenaltyBox/Message and IP) change to DB:
pbdb


Under Bayesian and Hidden Markov Model, uncheck Use BerkelyDB for the
Hidden Markov Model database(HMMusesBDB)

Apply changes, terminate ASSP.

Start ASSP

CHECK MAILLOG.  Make sure all is well.  Import should run.  Wait until
it is fully started again.

Terminate/Start ASSP.  Check logs again.

- Bob


On 6/1/2017 2:12 PM, James Moe wrote:
> On 06/01/2017 06:49 AM, Alexandre de Arruda Paes wrote:
>>
>> In assp base dir, do you have the file assp_db_import.cfg ?
>>
>    Yes. Here are the first two lines:
> # version='2.4.3';
> # modversion='(15119)';
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Whitelisting an IP is not working...

Andy Knuts
In reply to this post by James Moe-2
I'm trying to configure a remote iDRAC to be able to send me error messages in case of a failure. So I entered the IP address of my ASSP installation as an SMTP server for iDRAC. But testing fails...
I added the public IP address to my whiteListedIPs but it's still getting rejected like this:

Jun-02-17 13:34:50 m1-03290-02166 [Worker_2] x.x.x.x <idrac@[192.168.0.201]> Message-Score: added 39 (fiphValencePB) for Suspicious HELO - contains IP: '[192.168.0.201]', total score for this message is now 39
Jun-02-17 13:34:50 m1-03290-02166 [Worker_2] x.x.x.x <idrac@[192.168.0.201]> [scoring] (Suspicious HELO - contains IP: '[192.168.0.201]')
Jun-02-17 13:34:50 m1-03290-02166 [Worker_2] x.x.x.x <idrac@[192.168.0.201]> Message-Score: added 60 (fiphmValencePB) for IP in HELO '[192.168.0.201]' does not match IP in connection 'x.x.x.x' , total score for this message is now 99
Jun-02-17 13:34:50 m1-03290-02166 [Worker_2] x.x.x.x <idrac@[192.168.0.201]> [scoring] (IP in HELO '[192.168.0.201]' does not match IP in connection 'x.x.x.x' )
Jun-02-17 13:34:50 m1-03290-02166 [Worker_2] [MessageLimit] x.x.x.x <idrac@[192.168.0.201]> to: [hidden email] [spam found] (MessageScore 99, limit 50) [Alert from iDRAC] -> /var/db/assp/spam/Alert_from_iDRAC--375767.eml;
Jun-02-17 13:34:50 m1-03290-02166 [Worker_2] x.x.x.x <idrac@[192.168.0.201]> to: [hidden email] [SMTP Error] 554 5.7.1 Mail appears to be unsolicited


The IP 192.168.0.201 is the internal IP address of the iDRAC. The ip address x.x.x.x is the public IP address when IDRAC tries to access the internet over it's private netwerk.

How can I whitelist a single IP so it will always pass ?
The IP address x.x.x.x is already in my whiteListedIPs right now but it won't let it pass...

Thanks,
Andy

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Whitelisting an IP is not working...

Doug Lytle
>>> How can I whitelist a single IP so it will always pass ?

Add the IP Address to the Accept All Mail* (acceptAllMail)

Doug

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Getting ASSP to use Mysql

James Moe-2
In reply to this post by Robert K Coffman Jr. -Info From Data Corp.
On 06/01/2017 11:41 AM, Robert K Coffman Jr. -Info From Data Corp. wrote:
> Here are my notes from when I did this.
>
  Thank you!
  The bits about changing the entries to "DB:" were especially useful
since the docs were not clear about that.

  I am still having difficulty though not due to ASSP itself. The second
attempt following your outline failed also, because the perl DBD::mysql
module is not installed, and fails for reasons I do not understand. (See
"Getting ASSP to use Mysql" in the assp-test list.)

--
James Moe
moe dot james at sohnen-moe dot com
520.743.3936
Think.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Assp-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/assp-user
Loading...